28.03.2017: Fedora päivitetty versioon 25, koska 24:ssä oli outo bugi, jossa loginit (ssh ja sudo) kestivät jotain 30 sekunttia. Pelittää hyvin.

22.03.2017: En uskaltanut etänä sörkkiä, joten kotona vasta. Fedora päivitetty yön aikana, noin 4000 pakettia muuttui. Aloin väsymään ja menin vaan nukkumaan päivityksen ajaksi. Aamuun mennessä olikin jo 24 inessä.

21.03.2017: Alkanut mennä käpy villiintyneeseen OOMkilleriin, joka tappaa mielivaltaisesti mitä tahansa projekteja. En ymmärrä miksi, tätä ongelmaa ei ollut Fedora 22:ssa. Ajattelin päivittää etänä toimistolta 24:een ja siitä 25:een. Mikä voisi mennä pieleen?

17.01.2017: Jotain mystistä tapahtui kun verkko ja peikko putosivat. Käynnistettiin kone sekä verkkolaitteet uudestaan niin alkoi pelaamaan. Johdot olivat paikallaan yms. mutta jostain syystä iltakahdeksan jälkeen mikään bitti ei ollut liikkunut. Ei jaksa selvitellä kun nyt toimii taas.

14.11.2016: Roomba pudotti modeemin (Inteno DG301AL) lattialle ja sepä meni mykäksi. Kaikki valot palaa ihan sama mitä tekee, mäihällä sain toimimaan, mutta purkki pimenee 5min jälkeen. Jos toimii, pimenee aina 5min jälkeen. Kävin myymälässä, josta ohjasivat vikapalveluun, soitin sinne ja sen jälkeen kävin myymälässä hakemassa varamodeemin uutta odotellessa. Ainakin toimii nyt Technicolorin modeemilla teoreettista maksimia, sisään 83.16 mb/s, ulos 11.85 mb/s. Saa nähdä ehtiikö uusi tulla tällä viikolla.

29.11.2016: Fedora 23:n oom_killer oli aivan natsisäädöillä, joten tuunasin hieman ohjeen https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Performance_Tuning_Guide/s-memory-captun.html mukaisesti. Ainakin /proc/sys/kernel/msgmax säädetty 8192:sta oletukseen (65536). msgmnb oli 16384, nyt se on 65536. Pistin myös -17 (disabled) ainakin gmsync ja eggdrop pideille (/proc//oom_adj).

13.11.2016: Fedora päivitetty netin yli 22:sta 23:een. Meni aika sutjakkaasti ja putkeen. EOL Fedora 22:lla oli 19.7.2016: http://fedoraproject.org/wiki/End_of_life

12.11.2016: Pitkään oikutellut WD4000AAKS -kiintolevy hajosi lopullisesti. Ei mounttaa ja heittää I/O-erroria. Otin kovon pois ja rebootasin ja huomasin että bootti jäi emergency-modeen jumiin, koska /etc/fstab mountpointit oli vaihtaneet järjestystä. Entryt uusiksi ja homma rokkaa taas. Yhtä kovoa vähemmän tosin. No, vielä on ainakin 7 teran edestä tilaa. Kovon päällä lukee modelin alla Date: 17 JUL 2007. Olihan tuolla ikää.

10.11.2016: Jostain syystä yhteydet hidastuivat niin pahasti, että ei enää pingannut ulkoapäin. Pistin vaimolle viestiä että boottaa verkkolaitteet. Jotain pullonkaulaa yhteyksissä on, on ollut aina. En tiedä auttaako reitittimen uusiminenkaan ongelmaan... pitää vaan pärjätä.

25.10.2016: Tein tälle sivulle vähän uutta tyyliä. Muutokset githubissa: https://github.com/ronilaukkarinen/peikko - myös motd.php:n tyyli uudistettu: https://peikko.us/motd.php - EDIT: 22:51: Lisäsin myös "powered by" Sonera ja AdvancedTomato tuohon ylös. Pitäisi jaksaa muuntaa ikonit svg:ksi, mutta sen verran legacya koko tämä sivu, että taidan antaa olla.

24.10.2016: Vaihdoin oletus firmwaren takaisin AdvancedTomatoon, sillä myös ethernet oli luokattoman hidas, monesti speedtestillä suoraan routteriin 10mb/0.1mb. Vaihdon jälkeen heti parempi, mutta jotain mätää silti on. Mutta onhan tämä nätimpi. Taitaa Sonera vaan tökkiä nyt.

20.06.2016: Kotona tökki wlan ihan liian paljon, speedtest näytti aina jotain 2mb sisään ja 0.1mb ulos vaikka olisi ollut reitittimen vieressä, joten palautin uusimman stock-firmiksen, asuswrt:n joka on niinkin uusi kuin kuukausi sitten ilmestynyt. Ja heti parani nopeudet! 40/10 antaa speedtest wlanissa. TomatoUSBissa taisi olla jotain mätää.

05.05.2016: Nyt on peikollakin Let's Encryptin kautta HTTPS-sertifikaatti. Toimii siis myös osoitteessa https://peikko.us.

22.03.2016: Peikkoon ei saanut enää yhteyttä ja logi näytti "Read error on swap-device". Veikkaan että ylikuumeni, tai jotain. Manuaalinen reboot auttoi. https://dl.dropboxusercontent.com/u/18447700/2016-03-22%2000.16.01%20HDR.jpg

06.01.2016: Löysin tällaisen reaaliaikaisen topin. Tosi siisti! Tsekkaa: http://scout.peikko.us/

03.01.2016: Päivitin reitittimen firmwaren AdvancedTomatoon, koska asuswrt-merlinin RT-N16-version kehitys on lakkautettu. Vaikuttaisi toimivan hyvin. Ensin unohdin port forwardingit kokonaan ja ihmettelin miksei DDNS pelitä, mutta nyt toimii hyvin, jopa sutjakkaammin, tai sitten kuvittelen vaan.

02.01.2016: Hyvää uutta vuotta! Otin olohuoneen kotiteatterikoneesta kuudennen kovalevyn peikkoon kiinni, sillä se on siinä vähän turha, koska olohuoneen kone on vain player joka toistaa Peikon Plex-serveriltä suoraan. Menee vähän gigat hukkaan. Huomasin että netin configurointi menee NetworkManagerin ja nmcli kautta ja sehän ei IP:tä löytänyt ollenkaan... eikun nmcli --help ja opettelemaan. Hyvin meni ja nyt bootissa hakee staattisen IP:n suoraan.

30.12.2015: Uutta rautaa! Tilasin 22.11.2015 uutta rautaa kun huomasin että Plex vaatii vähän enemmän tehoja ja kone on aina vähän jökissä tällä käyttäjämäärällä. Kotelossa kesti pitkään, joten sain kamat vasta tänään, mutta ai että kun se on nätti! Tässä kuvia (1): https://www.instagram.com/p/_6-v0IG0VD/ (2) https://www.instagram.com/p/_62Cx5m0f_/. Uudet osat: Cooltek C2 mATX-alumiinikotelo musta, Intel Haswell Core i3-4150 LGA1150 3.5GHz 3MB, AsRock H81M-GL LGA1150 Intel H81 DDR3 mATX, Silverstone 500W Strider Essential-230 ATX 2.3 80 Plus musta, Kingston 8GB(2x4GB) HyperX Savage DDR3 1600MHz. Nyt on lisäksi 6 SATA-paikkaa, joten kaikki 5 kiintolevyä mahtuvat ja tilaa riittää. Upea tunne kun kaikki toimii niin nopeasti.

05.09.2015: Taisin löytää bugin. Nimittäin dnf remove -ongelma tapahtui uudestaan, tällä kertaa postgresql:n kanssa... Irkistä sain Freenoden #fedora-kanavalta vinkkejä ja lopulta ratkoin ongelman itse. Bugi-ilmoitus täällä: https://bugzilla.redhat.com/show_bug.cgi?id=1260299 . Tämän sivun lähdekoodi on muuten nyt avoimena GitHubissa: https://github.com/ronilaukkarinen/peikko

04.09.2015: Hohhoijaa. dnf remove skype poisti samalla zlibin, joka on yksi fedoran keskeisimpiä kirjastoja ja tämän myötä mm. sudo, dnf, rpm ja wget lakkasivat toimimasta. Eikun reinstallaamaan ja sillä tiellä ollaan... kaikki palautettu, mutta menee taas ehkä koko yö ennen kuin saan kaiken valmiiksi. Koska nukkuahan ei voi ennen kuin serveri toimii täysin entisellään.

01.09.2015: Olen pitkään jo haaveillut python 2.7:stä testatakseni mopidya, sekä uudemmasta irssistä testatakseni uusia scriptejä ja parannellakseni weediä, joten päätin kokeilla CentOSin päivitystä httpftpfs:n kautta. Mutta kylläpä se pieleen meni... rikkinäinen systeemi, joten backupit ja miettimään mitä seuraavaksi. Fedora on vielä rpm-pohjaisista kokeilematta, joten se sisään. Ja tämähän vaikuttaa kurkolta. Nyt asennuspuuhia, todennäköisesti taas läpi yön... Kuva: https://instagram.com/p/7GStg6m0Qa/

01.08.2015: Muutettiin juuri keskustaan! SATA-piuha oli vähän höllällä, mutta kyllä vaan boottasi uuteen kämppään kivasti :) Otin Instgramiinkin kuvan: https://instagram.com/p/52rCaGG0fm/

30.07.2015: Soneralla oli valtakunnallisia ongelmia, myös kauhia ukkospäivä. Yli 12h alhaalla...

19.03.2015: Asennettu SATA-lisäpaikat PCI-E-väylään, mutta powerissa ei riitä virtaa... pitää ostaa uusi emokin jos aion kaikki 6 kovoa saada. Korvasin 1TB WD:n 3TB WD30ERFX:lla. Nimesin kovon Giantiksi. Uptimea meni sellaiset yli puoli vuotta.

04.03.2015: Reitittimen firmware päivitetty uusimpaan eli 378.50: https://www.mediafire.com/folder/bkfq2a6aebq68/Asuswrt-Merlin#yvgnw5wo8wrco

17.02.2015: Index siirretty oman boilerplaten päälle: https://github.com/ronilaukkarinen/modern-html5-boilerplate . Serveri toimii vakaasti ja hyvin.

17.11.2014: Pätkiminen harmillisesti alkanut taas. Päivitin ASUS RT-N16 -reitittimen asuswrt-merlin -firmiksen uusimpaan marraskuun versioon.

13.10.2014: Sähkökatkos, pari tuntia serveri down. http://www.ksml.fi/uutiset/keski-suomi/sahkot-poikki-tuhansilta-jyvaskylassa/1913204

9.9.2014: Kun eilen selvisikin Subsonicin "UPnP-ongelma", laitoin nyt asuswrt-merlinin uusimman version takaisin - se on tällä hetkellä kaikista nopein firmware ja tuntuu serverikin pyörivän jouheasti. Lisäksi yksi uusi käyttäjä lisätty Plexiini.

8.9.2014: Kokeilin OpenWRT:tä kun sitä niin paljon suositeltiin, mutta se on tehty ihan älyttömän vaikeaksi conffia. Tarvitsen serverissäni niin paljon palikoita että en ala koko päivää käyttämään siihen että conffin ruohonjuuritasolta wifistä lähtien kaikki. DD-WRT:ssä tulee paljon automaattisena mikä on hyvä juttu.

7.9.2014: Selvisi että Subsonicin ongelma johtuikin Google Chrome Canary buildista... eli ei olisi tarvinnut palata dd-wrt:hen. No, tämä DD-WRT v24-sp2 (06/07/14) kingkong 22000M tuntuisi olevan vakaa ja luotettava. Pidetään peukkuja. Luulin oikeasti kyseessä olevan reititin ja että serveri ei saa asetuksia tai jotain niin asensin kaikki CentOSin päivitykset ja reboottasin samalla menettäen 52 päivän uptimet. No, onpahan nyt kaikki ajan tasalla.

7.9.2014: asuswrt-merlinin kanssa tuli vastaan 2 ongelmaa: Vain yhtä DDNS-hostia voi päivittää kerrallaan (fiksasin tämän tosin wildcardilla) ja Subsonic ei tunnista reititittimen UPnP:tä ollenkaan, edes manuaalinen port forward ei auta. Joten oli pakko siirtyä dd-wrt:seen. Testasin lukuisia buildeja ja on turhauttavaa ettei meinaa löytyä netistä oikein tietoa mikä on hyvä. Fractal buildeissa 21598 ja 23387 (dd-wrt.v24-21598_NEWD-2_K3.x_big_RT-N16 ja dd-wrt.v24-23387_NEWD-2_K2.6_mega) ei toimi Wlan ollenkaan. BrainSlayerin buildit ovat liian vanhaa tai niissä ei ole tarvittavia ominaisuuksia. Joten nyt on kingkongin nv32k-versio ja tuntuu toimivan moitteetta. Toivotaan että jatkuukin toimiminen hyvin.

6.9.2014: Vain pari kertaa pätkässyt, en tiedä tekikö Sonera mitään, vaikka ilmoittikin ongelman ratkenneen. Asensin dd-wrt kingkong 22200+ version tilalle asuswrt-merlin RT-N16_3.0.0.4_376.44_0 2014-08-17 ja tuntuupa muuten nopealta! jos tämän kanssa ei esiinny mitään ongelmia niin tähän jään.

3.9.2014: Soneran päässä tuskin mitään oli, sillä reititin resetoituu itsestään. Löytyi ketju, jossa pohditaan samaa ongelmaa http://forums.whirlpool.net.au/archive/1916928. Disabloin traff Daemonin ja UPnP porttien tallennuksen ja jos se ei auta niin kokeilen eri firmwarea.

2.9.2014: Jotain mätää viime aikoina kun on tökkinyt. Laitoin eilen Soneralle vikailmoitusta ja tänään tuli ilmotus että korjattu. Tuntuisi toimivan nyt taas normaalisti. Toivon mukaan korjaantui.

11.7.2014: Netti on toiminut mainiosti, mutta nyt serveri oli kaatunut klo 7.24 aamulla. Ei mitään tietoa miksi. Logeihinkaan ei jäänyt mitään... toivottavasti vuodenvaihteinen jäätyily ei ala taas. Sinne meni n. 170 päivän uptimet... päivitykset serverille ajettu myös.

7.7.2014: Netin pätkiminen on jatkunut ja olen laittanut toistuvaa vikailmoitusta Soneralle. Vihdoin he korjasivat asian soittamalla paikalle asentajan. Empowerin asentaja rassasi seinää jonkin aikaa ja sitten kertoi ottaneensa 2 käyttämätöntä rasiaa pois käytöstä ja parannellessaan "haaroituksia", tms. Joka tapauksessa, pätkiminen loppui ja netti on toiminut loistavasti putkeen. Nopeudetkin ovat nyt lähellä teoreettista, yli 10mbit up ja yli 80mbit dl. Hyvä Sonera!

25.6.2014: Soneralla tapahtui jotain, koska yhteys reitittimen ja modeemin välillä katkesi klo 8:25. Otin yhteyttä ja korjasivat tilanteen samana iltana. Samalla päivittyi firmis.

20.5.2014: Ukkosti kovasti viime yönä ja modeemi ei toiminut enää. Ei auttaneet bootit, joten piti resetoida ja ottaa Soneraan yhteys että laittavat taas nelosportin siltaavaksi jotta yhteys reitittimeen toimii oikein. Nopea vastaus Sonera_Palvelu-twitterissä jälleen kerran.

7.4.2014: Jotain hämärää tapahtui klo 01.31 kun netti katkesi. Aamulla huomasin, että modeemin valot huutaa punaista. Käynnistin molemmat verkkolaitteet uudestaan ja modeemi resetoitui... onneksi oli backuppi. Kummallista. Sähkökatkos, ehkä.

9.1.2014 16:50: Sähkökatkos klo 13.01. Kesti muutamia minuutteja, mutta serveri sammui ja reititin resetoitui. Nyt asetukset ja portit auki uusiksi dd-wrt:een ja tällä kertaa otan backupit, jotta ensi katkoksen aikaan on helpompi palauttaa! Ei muuten käynyt serverille kuinkaan, pyörii edelleen täydellisesti!

9.1.2014: Laitoin vihdoin paveq:n lahjoittaman kovon kiinni, johon rsyncillä backupit rullaamaan. Pistin myös boottiscriptit vihdoin kuntoon. Boottaa muuten aika nopeasti vaikka on paljon palveluja käynnistyksessä, jopa 40 sekuntiin! Tosi tyytyväinen olen tähän asti ollut CentOS 6.5:een. Paveq:lle vinkistäkin vielä kiitokset.

7.1.2014 22:26: Kaikki palvelut taas käytössä. Sysmon-ws:n kanssa oli vähän säätäminen kun ei toiminut CentOSin omalla python-versiolla suoraan (2.6) vaan piti asentaa rinnalle 2.7.

7.1.2014: Kaikki paitsi sysmon saatu nyt vihdoin kuntoon. Ja hyvin on uptimet pysyneet!

6.1.2014: Peikko pyörii nyt onnellisesti CentOS:lla. RPM-pohjaisista paras vaihtoehto ja serverikäytössä kehuttu netissä. OpenSUSE 13.1:ssä oli jonkun minun juttujen kanssa esiintyvä kernel-bugi, enkä jaksanut enää lähteä selvittelemään. Tämä on pysynyt päällä yhdeltä istumalta. Ja on muuten hyvä! Vielä on paljon kopsaamatta, asentamatta ja päivittämättä (kuten alla oleva sysmon ei nyt vielä toimi). Siistiä kumminkin! Kello on 4:12 (taas!), eli nyt nukkumaan...

5.1.2014: MITÄÄH. Pistin KAIKKI (paitsi 1 kovo jota en käytä eikä ole mountattuna) ja SILTI jäätyi! Nyt alkaa mennä uskomattomaksi. Logissa näkyy DWARF2 unwinder stuck ja kernel null pointer exceptionia. Selvittely jatkuu täällä: https://forums.opensuse.org/english/get-technical-help-here/hardware/493935-opensuse-13-1-i586-server-hangs-freezes-gets-unresponsive-randomly.html#post2613841

4.1.2014: Uskomatonta! Tänään laittaessani juttuja uusiksi serveri jäätyi TAAS. Vanha kovo on irrotettu. Unohdin heittää setterm -powersave off -blank 0 monitoriin, joten en saanut sitä hereille: en nähnyt mihin logi jämähti... tässä on taas selvitteleminen voiko toinenkin kovo olla rikki (1 TB Western Digital Green) vai onko se todellakin emolevy.

Kävi päivän mittaan ilmi, että toisellakin kovalevyllä on bad sectoreita ja aina kun sinne koittaa kirjoittaa paljon dataa kerralla, esim torrent-liikenne jumittaa systeemin kokonaan. Mitään ilmiselvää ei logiin tule. Kävi tuuri ja Mechalla oli ylimääräinen kokoonpano ilman kovoa, paveq lähetti minulle oman käytetyn kovonsa Oulusta joten sain aika hyvin varaosia uuteen serveriin.

Mechan kokoonpano toimii paljon nopeammin. Pelkät kovot kun kiinnitti niin logi heitti [ 1409.332695] mei_me 0000:00:03.0: unexpected reset: dev_state = RESETTING tyylistä floodia jatkuvalla syötöllä ja tajusin että uudelle kokoonpanolle systeemi pitää asentaa uudestaan. Siispä, taas asennushommiin...

Asennus meni heittämällä, formatoin taas kovon, mutta käynnistäessä tuli floodia [65.456035] mei_me 0000:00:03.0: reset: connect/disconnect timeout. jopa komentorivikehoitteeseen asti. Liittyy jotenkin Intel ME (Management Engine):een, mitään hajua mikä se on. Googlasin ja ratkaisu olisi ollut sudo rmmod mei-me, mutta minulla heitti että koko mei_me moduulia ei ole edes asennettu.

Lisägoogletuksella kävi ilmi että tässä Compaqin/HP:n emo-prossu-yhdistelmässä on Intel ME -asetuspaneeli erillään BIOSista, johon pääsee CTRL+P-näppäinyhdistelmällä koneen käynnistyessä. Salasana on oletuksena admin ja eteenpäin ei päässyt ennen kuin sen vaihtoi. No, ei antanut vaihtaa edes vaikeaa salasanaa. Piti googlata taas ja selvisi http://software.intel.com/en-us/blogs/2007/11/08/strong-amt-me-passwords-and-other-shades-of-gray/ että salasana pitää olla erittäin vaikea. Sitten pääsin lykkäämään ME-controllerin (mikälie) pois päältä, jonka jälkeen käynnistyi kahdesti uudestaan ja ei tullut enää ikinä sitä samaa floodia. Jes!

Kliini systeemi ja sitten alkaa hommista isoin: tiedostojen siirtely.

3.1.2014: Homma jatkui tänään, mutta harmikseni huomasin BTRFS:n epäluotettavaksi yhäkin, sillä jouduin emergency modeen enkä päässyt siitä pois. Tämä johtui varmaan varmuuskopioinnin aikana tapahtuneesta jumiutumisesta jolloin vähän hätäisesti väkisin sammutin koneen. Ei elpynyt enää. Ei olekaan niin turvallinen vielä tuo BTRFS-tiedostojärjestelmä. Lisää: http://lists.opensuse.org/opensuse-factory/2013-09/msg00359.html

Piti myös varmuuskopioida /-osio uudestaan koska huomasin että vanhalla kovolla oli vanha systemosio jonka olin kopioinut... en ollut käyttänyt tätä osiota vuodesta 2010. Aika paljon turhaa tavaraa muutenkin niiltä ajoilta kun käytin GUI:ta.

2.1.2014: Seagaten 320 GB kiintolevy sanoi sitten vihdoin itsensä irti eilen https://twitter.com/rolle/status/418494763990401024. Tänään töiden jälkeen ryhdyin tuumasta toimeen, asensin Knoppixin tikulle boottaavaksi, tyhjensin toisen koneen (Turmion) kiintolevyn saman koneen toiseen kiintolevyyn ja poistin turhat tiedostot. Formatoin gpartedilla tyhjäksi ja poistin osiot. Sitten asensin Knoppixilla toiselle tikulle uusimman susen boottaavaksi ja siirryin serverikoneelle, johon kiinnitin tyhjentämäni WD 500 GB kovon. Yritin asentaa tikulta, mutta setuppi jumahti Searching for Linux partitions 60% ja tajusin että se yritti etsiä joko cd-asemaa tai diskettiasemaa (joita ei ole) tai viallista levyä joka oli vielä kiinni ja jämähti siihen. Otin levyn irti ja heitin acpi=off asetuksen, ja asennus sai jatkua.

Asennus suoraan runlevel 3:seen ja backupit rullaamaan cp -Rv:llä toiselta levyltä mounttauksen jälkeen https://vine.co/v/hVY7WYwIpTd. Laitoin muuten koko systeemin BTRFS-filesysteemillä, joka on kuulemma todella hyvä ja joustava ja vihdoin "turvallinen käyttäjille" openSUSE:lla. Mitä nyt pienellä googlauksella selvisi niin BTRFS:ssä on siistejä ominaisuuksia, tietysti kräshäyksen kestävämpi ja pystyy mm. suurentamaan osiota lennosta vaikka on mountattuna. Wou.

Roottiosion backuppaus onnistui heittämällä, mutta home-osion mounttaaminen heitti bad superblockia koko ajan, eikä antanut mountata. KNOPPIX tunnisti levyn, mutta en saanut uutta suseani sitten mountattua, koska olin asentanut sen BTRFS-filesystemille, jota KNOPPIXin versio ei tukenut... piti sitten tyhjentää 10 gigaa vielä toiselta kovolta ja siirtää home-osion backup sinne. Mutta sekään ei auttanut kun kesken kopioinnin koko KNOPPIX jämähti... liian rikki.

Testdiskillä lopulta sain home-osion pelastettua vielä.

30.12.2013: Taisin selvittää serverin kaatumisongelman. Prossutuuletin on saattanut jotenkin vioittua, koska jos prosessori käy 100% yli 10 min niin se throttlaa yli 90 asteen lämmöissä. Perl-prosessi (pisg) veti prossun vartin ajaksi liian kuumaksi. Selvitin tämän tekemällä bash-scriptin, joka ilmoittaa Pushoverilla suoraan puhelimeeni kun serverin prosessori käy liian kuumana. Pisgiin olikin kertynyt prosessoitavia logeja jo viiden vuoden ajalta, joten ei ihme että laskennat kuormittivat prossua. Piti ottaa tämä cronjobi pois ja nyt on serveri pyörinyt normaalisti puolitoista vuorokautta. JOS siis syy on tämä. Todennäköisimmin on. Yay!

29.12.2013: OK, alkaa olla aika toivoton olo. Jäätyilee silti. Ydinten lämmöt heittelee 40-70 asteen välillä, 74 ilmeisesti kriittinen, eli voi ollakin vielä jäähdytyksessä vika. Logeihin ei jää mitään muuta kuin mystinen ^@^@^@^@^@^@^@^@ -raita. Äh, voisin kirjoittaa tästä blogiini mieluummin, jos saisin jopa vastauksia...

28.12.2013: Otin BIOSista kaikki tuulettimen kontrollointiin liittyvät pois päältä ja nyt antaa 1700 RPM aiemman 800 RPM sijasta. Eipä vaikuttanut kyllä jäähdytykseen paljoa mitenkään. Säädin jotain muutakin BIOSista, jospa nyt toimisi jatkossa. Löysin muuten Asuksen näyttiksen jolla on parempi testailla kuin tuolla vanhalla GeForcella joka näyttää lumisadetta (hyvä että näkee jotain). Jospa näillä säädöillä serveri jaksaisi pyöriä... nyt on näytössä aina kaapissa /var/log/messages aina auki, joten ainakin näkee mihin kohtaan jäätyy näytön avaamalla. Cooleria varmaan voisi hankkia, esim. tällaista: http://www.jimms.fi/tuote/100700542 tai http://www.jimms.fi/tuote/CNPS8900-EXTREME tai http://www.jimms.fi/tuote/SCBSK-2100

27.12.2013: Kävin ostamassa piitahnaa Kampus Datasta. Laittelin prossun päälle uudet tahnat puhdistettuani vanhoista. Onnistuin neljännen pinnin prossukruunusta rikkomaan ja en tiedä onko se nyt hyvin paikallaan... ei vaikuttanut juurikaan lämpötiloihin. Tarkkaillaan taas. 27.12.2013 klo 19.24.52 taas verkossa. Lasketaan uptimeä tästä eteenpäin.

26.12.2013 22:54: Kaatumistiheys tihenee. Vaihdoin virtalähteen Deltaco 350W:sta hyllystäni löytyneeseen toimettomaan Nexus NX-3500:een. Lisäksi vaihdoin 2 KVR533D2N4/512:sta yhteen KVR533D2N4/1G-muistikampaan. Epäilen kyllä ylikuumenemista vieläkin, josko prossun piitahnat menneet tai jotain.

26.12.2013 21:52: Ei silti pysynyt kuin muutaman tunnin jäätymättä... selvittelyt jatkuu...

26.12.2013: Otin koko koneen ulos, irrotin osat, imuroin kaikki, poistin vanhan näyttiksen, wlan-verkkokortin ja vanhan kiintolevyn. Lämmöt putosi 10 asteella! Kannatti. Jos nyt vielä jäätyy niin ihmettelen. http://instagram.com/p/iYwiqHm0Zk/

25.12.2013: Okei, se teki sen taas. Mikäköhän siinä on... pitänee hajottaa koko kone atomeiksi ja selvitellä.

23.12.2013: Pari viikkoa oli kaatumatta, mutta nyt taas kaatui. Juuri ennen kaatumista logissa näkyi 2013-12-23T00:00:03.887530+02:00 peikko /USR/SBIN/CRON[20991]: (rolle) CMD. Otin crontabista paljon vanhaa turhaa pois, vissiin kuormittanut liikaa serveriä... jos nyt pelittäisi pidempään.
07.12.2013: Ja toisen kerran jäätyi vuorokauden sisään. Ei vastannut pingiin, vain reset auttoi. Lämpötilat ok, eli ehkä jotain muuta sitten. Laitoin kuitenkin Q-Fanin päälle, oli jostain syystä Disabled, nyt Performance-modella. Epäilen että kyseessä on näyttis, nimittäin uusi ajuri asennettu hiljattain ja fyysisellä näytöllä näkyy enimmäkseen lumisadetta... poistin kaikki näyttiksen ajurit ja otin kaikki headless-prosessit pois päältä, katsotaan auttaako. Skype-serveri on nyt offline, eli todennäköisesti näet minua skypessä online vain työaikoina jatkossa.
04.12.2013: Ei mitään hajua miksi crashasi. Katsoin Plexillä elokuvaa. Tehnyt saman kerran aiemminkin pari viikkoa sitten...
30.11.2013: Päivitin Susen versiosta 12.3 versioon 13.1. Kernel, python, TCL, Samba ja monet muut päivittyivät ja vaati vähän säätöä että sain taas kaiken toimimaan.
27.11.2013: Palvelin kyykkäsi tuntemattomasta syystä. Taitaa alkaa olla rauta jo sen verran vanhaa... resetti auttoi.
14.10.2013: LAMPP (Linux Apache MySQL, PHP, Perl) päivitetty versiosta 1.7.7 (2011-09-19) versioon 1.8.3-1 (2013-8-30).
13.10.2013: Uudistin serverin etusivun (peikko.us). Edellinen löytyy peikko.us/index_2013.php, sitäkin vanhempi peikko.us/index_vanha.html. Päivittelen taas hiljalleen.
11.10.2013: openSUSE päivitetty 12.2:sta 12.3:een. Samalla purkki otettu kaapista ulos ja todettu näyttiksen hapettuneen. Oli paha conffia sokkona kun SSHD ei pelannut... vaan nyt toimii taas.
05.09.2013: Inteno DG301AL:n sai vikailmoitus-pyynnöllä siltaavaksi, joten enää ei tarvitse Zyxeliä välittäjänä.
16.08.2013: NATit, DCHP:t ja WLANit, sekä kaikki muut ylimääräiset bokseista pois ja ainoastaan Asus RT-N16 reittimen dd-wrt:hen hyvät asetukset. Nyt on kaksi modeemia kiinni ja Soneran 100/10 SEKÄ KotiTV toimivat loistavasti.
11.08.2013: Vaihdoin sitten Soneran 100/10 valokuituun. 8.8. meni päälle, mutta boksia ei saanut siltaavaksi. 9.8. hain uuden boksin. Tänään vihdoin tulilla, mutta nopeus ei ihan vastaa satamegaista... http://peikko.us/2894686224.png kuulemma ei ole vielä kytketty lopullisesti. Ensi viikolla ihmetellään lisää.
17.06.2013: Elisan 20/1 ADSL on hidastellut älyttömästi viime aikoina. Resetoin verkkolaitteet kolmesti ja vaihdon muoveista uudet johdot. Ennen: http://peikko.us/elisa-ennen-2826211733.png, jälkeen: http://peikko.us/elisa-jalkeen-2843070989.png
11.06.2013: Palvelin siirretty kaappiin kun tytär välillä painoi nappia ja muutenkin vähän tiellä. Nyt parempi.
07.06.2013: Hirveä ukonilma iltapäivällä kyykkäsi netin ja boottasi laitteet. Netti oli katki vuorokauden, ennen kuin Elisa sai korjattua vian.
20.05.2013: Palvelin kyykkäsi tuntemattomasta syystä 9:46, reboottasi itsensä. Pitänee tutkia syytä...
04.05.2013: Muutto hoidettu. Uudessa kämpässä Elisan FullRate ADSL 20/1, eli hitautta tiedossa...
28.04.2013: Pöytä siirretty ikkunan edestä, jotta voi pestä ikkunat. Muuttoimurointia, johtojen siivousta. Koneen sisusta myös imuroitu.
04.04.2013: Saunalahdella valtakunnallisia ongelmia laajakaistoissa. Netti pari tuntia katki.
20.03.2013: Domain vihdoin siirretty no-IP.comiin. Ei enää manuaalisia IP:n päivityksiä!
12.03.2013: Saunalahti katkaisi kaapelinetin JVA:n talouksissa. Tilalla 100/10 valokuitu. Uusi modeemi asennettu siltaavaksi.
08.03.2013: Koneen sisusta imuroitu enimmästä pölystä.
07.03.2013: Asennettu ASUS RT-N16 -reititin, johon uusin dd-wrt.
14.02.2013: openSUSE päivitetty versiosta 12.1 versioon 12.2. Hyvin toimi zypper dup.
13.02.2013: Puoli gigaa päivityksiä, reboot: joku meni pieleen eikä startannut. Komentoriville exit ja kone taas starttiin...
24.11.2012: Anoppi sammutti koneen kun oli hoitamassa Lottaa ollessamme reissussa. Ei saanut unta kuulemma koneen hurinassa.
16.10.2012: Yli neljä tuntia kestävä sähkökatkos.
15.09.2012: Hirveä määrä päivityksiä ja niin paljon säätöjä että ajattelin reboottaa... Kauan ehti päällä ollakin yhteen menoon: 15.9.2012 20:25 käynnissä 227 vrk 22:05, 4 käyttäjää, keskimääräinen kuorma: 6,04, 4,85, 3,68
21.01.2012: Vaihdettu OpenDNS:ään, rebootattu, huomattu profiilin kusseen... mv /home/rolle /home/rolle_backup ja profiili uusiksi...
01.12.2011: openSUSE päivitetty versiosta 11.4 versioon 12.1. Tilalle paljon uutta ja Gnome 3. On totuttelemista.
16.10.2011: Peikon sisuskalut imuroitu enimmästä pölystä.
08.09.2011: Tein yli 200mb edestä päivityksiä. Käynnistin myös X:n uudelleen. Yhyy, sinne meni 126 päivän uptimet.

Vanhemmat:
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
28.12.2010:
Peikko oli hämärästi jäätynyt anopin luona sukuloidessamme. Viimeisin toiminto
oli rajatpois -komento, ja järjestelmälokissa ilmoitus:
Dec 27 02:00:02 peikko /usr/sbin/cron[27310]: (rolle) CMD (perl /home/rolle/
pisg/pisg), eli näemmä kone jotenkin ylikuormittunut. Outo juttu, toivottavasti
pysyy nyt vähän vakaampana.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
25.07.2010:
Ukkosti aika rankasti, joten kone oli hetken kiinni.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
20.07.2010:
Päätin vihdoin ryhtyä päivittämään käyttöjärjestelmää versioon 11.3, joka jul-
kaistiin 17. heinäkuuta. Itse päivitys sujui hyvin, mutta heti bootin jälkeen
kohtasin ongelmia X:n ja nvidian kanssa. Nvidian ajurit eivät lähteneet aluksi
ollenkaan pelittämään... viiden tunnin väännön jälkeen sain kaiken toimimaan
kuten pitääkin. Asennukseen käytin: http://en.opensuse.org/SDB:NVIDIA_drivers
"Hard way" -ohjetta, mutta en silläkään saanut suoraan toimimaan, vaan jouduin
nvidia-settingsistä roottina asettelemaan näytöt auto-resoluutiolle ja Twin-
viewiin jolloin sain composition päälle...

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
23.06.2010:
Saunalahti päätti sitten päivittää modeemin firmwaren verkon yli "huonompaan",
jolloin reitittimellä ei ollut enää virkaa kun portit eivät enää olleet siltaa-
vana. Lähetin äkäistä meiliä ja samaisena yönä he päivittivät firmwaren toista-
miseen. Nyt modeemissa ei edelleenkään ole hallintapaneelia, mutta sen saa
vaihdettua siltaavaksi. Reititin perään kiinni ja asetukset uusiksi... Nyt
toimii taas.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
02.06.2010:
Nettiliittymä vaihtui Elisan 30/1:sta Saunalahden 100/5-yhteyteen. Uudessa Be-
wan iBoxissa ei kuitenkaan voinut availla portteja joita olisin halunnut...
loukin ystävällisellä avustuksella sain modeemin siltaavaksi ja sain lykättyä
reitittimen siihen kiinni, jolloin porttien avaaminen onnistui. Pitkän taiste-
lun jälkeen serverin pitäisi nyt toimia taas.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
23.03.2010:
Menin tekemään vahingossa tuhoja rm -komennolla, ja järjestelmä oli muutenkin
sekaisin kun olin asennellut liian paljon sourcesta ohjelmia, ja lisännyt yli-
määräisiä ohjelmistolähteitä... palautin tärkeimmät asiat varmuuskopioista,
joten en hävinnyt reinstallissa mitään. Nyt on eheä systeemi!

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
26.01.2010:
Western Digital Caviar Green 1TB asennettu tietokoneeseen. Eipähän hetkeen
lopu tila kesken. Etusivu (http://peikko.us) voi toistaiseksi näyttää oudolta,
sillä tnnetin shellini päivitettiin Shell Teho -pakettiin, eikä siksi nykyinen
IRC-tila näy ilman php-erroreita (ohjaa vielä vanhaan Shell Perus -urliin).
Vikaa korjataan parhaillaan.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
13.01.2010:
Talosta paloi sulake 21:01. Huoltoasemalla ei ollut, mutta onneksi canflyllä
oli ylimääräinen. Kiitos canfly, pelastit peikon <3. Peikko oli parisen tuntia
offline.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
12.11.2009:
OpenSUSE päivitetty versioon 11.2 heti kun julkaisu koitti. Samba päivittyi,
eikä enää toiminut samalla tavalla. Samban conf siirtynyt /etc/smb.conf:sta
/etc/samba/smb.conf, mikä hieman hämäsi.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
13.09.2009:
OpenSUSE 11.1 vihdoinkin saatu asennettua uudestaan, ja kustomoitua
entisen näköiseksi. Deltacon 350W virtalähde tosiaan hapettui
käyttökelvottomaksi, jonka myötä kaksi (2) kiintolevyä hajosi. Nyt peikko
pyörii uuden Seagaten 500gb -kovon päällä.

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-